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Quick Access Toolbar 

 The Quick Access Toolbar is just to the right of the Microsoft Office Button. 

 When the cursor is over a button, the name of the button is displayed. 

 The options available when Microsoft Office 2007 is first installed include Save, Undo, and Redo. 

Customizing the Quick Access Toolbar 

 To add an item, click on the Customize Quick Access Toolbar drop down arrow at the end of the Quick 

Access Toolbar and click on the desired item. 

 Options with a check mark in front of them are displayed on the Quick Access Toolbar. 

 To remove a button, click on the Customize Quick Access Toolbar drop down arrow at 

the end of the Quick Access Toolbar and click on the desired item. (This removes the 

checkmark from in front of the item.) 

 To add a command button from the Ribbon, right click on the desired command button 

and choose Add to Quick Access Toolbar. 

 To remove a command button that has been added to the Quick Access Toolbar, right 

click on the button on the Quick Access Toolbar and choose Remove from Quick 

Access Toolbar.  

Customizing Excel 

 Click on the Microsoft Office Button and then click on the Excel Options button at the bottom. 

 Popular – Click on Popular to change options for creating new workbooks. 

o In the When creating new workbooks section, the font, font size, default view, and number of 

worksheets in a new workbook can be specified. 

 Formulas – Click on Formulas to change options for formulas and error checking. 

 Proofing – Click on Proofing to change AutoCorrect options. 

 Save – Click on Save to change the AutoRecover options. 

 Advance – Click on Advanced to change editing options and display options. 

o In the Print section, the High quality mode for graphics can be turned on to enhance the printing 

of graphics. 

 Click on OK. 

Keyboard Shortcuts 

 Press the Alt key on the keyboard to display the keystrokes for the tabs and Mini toolbar. 

 Press the desired key such as H for the Home tab. 

 Continue pressing the indicated keys and/or down arrow to make the desired choices. 

 To remove the keystroke markers from the screen, press the Alt key. 

Moving Through the Spreadsheet 

Keyboard Method 

 Press the Scroll Lock key on the keyboard (top right side). 

 The arrow keys on the keyboard now move the spreadsheet instead of moving from cell to cell. 

 Press on the Scroll Lock key again to turn off this feature. 

Scrolling Mouse 

 Press the wheel on the scrolling mouse. 

 Move the mouse (no clicking) and the spreadsheet moves. 

 The farther from the marker, the faster the spreadsheet moves. 

 To turn off this feature, left click or press on the wheel again. 
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Up and Down Arrow Keys 

 Arrow keys - move one cell in the direction of the arrow. 

 Control  or Control  - moves to the next cell with information or to the far edge of the worksheet. 

Page Up and Page Down Keys 

 Page Up and Page Down - move one full screen at a time up or down through the worksheet. 

 Control Page Up and Control Page Down - moves from worksheet to worksheet. 

Status Bar 

 The Status Bar is at the bottom of the window. 

 Click and drag to highlight cells with numbers. 

 Notice the right end of the Status Bar. It usually indicates several calculations with the selected numbers. 

 Right click on the Status Bar and click to place a checkmark next to the desired items in the list. 

o Average – Displays the average of the selected numbers. 

o Count – Displays the number of cells selected that contain information. 

o Numerical Count– Displays the number of cells with numbers. 

o Min – Displays the smallest number in the selection. 

o Max – Displays the largest number in the selection. 

o Sum – Displays the total of the numbers in the selected cells. 

 Click away from the window when finished. 

Worksheets 

Renaming a Worksheet 

 Double click on the worksheet tab. 

 Type in the name. 

 Press the Enter key. 

Showing/Hiding Gridlines 

 On the Ribbon, click on the View tab. 

 In the Show/Hide group, a check mark in the Gridlines box indicates the gridlines 

are showing. 

 Click in the Gridlines box to make a change. 

Coloring the Worksheet Tab 

 Right click on the tab of the sheet. 

 Click on Tab Color…. 

 Click on the desired color. 

 Note – When the tab is selected, the color shows as a stripe at the 

bottom. When the tab is not selected, the entire tab shows the color. 

Moving a Worksheet to another Workbook 

 Be sure both workbooks are open. 

 Right click on the tab of the worksheet and choose Move or Copy.... 

 Click on the down arrow below To book and choose the destination 

workbook. 

 In the Before sheet window, choose the worksheet it should come before. 
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Copying a Worksheet within the Workbook 

 Click on the tab of the worksheet to be copied. 

 Hold down the Control key while clicking and dragging the worksheet to the side. 

 Release the Control key when the worksheet is successfully copied. 

Copying a Worksheet to another Workbook 

 Be sure both workbooks are open unless the sheet is being moved to a new workbook. 

 Right click on the tab of the worksheet and choose Move or Copy.... 

 Click to select Create a copy at the bottom of the window. 

 Click on the To book down arrow and choose the destination workbook. 

 In the Before sheet window, choose the worksheet it should come before. 

 Click on OK. 

Group Column/Row Adjusments 

 Multiple columns can be adjusted to have the same width.  

 Multiple rows can be adjusted to have the same height. 

 Columns 

o Click and drag over the letters of the columns (top edge) to highlight the desired columns. 

o Move the cursor to a line between the column letters at the top (two-headed arrow). 

o Click and drag to adjust the width of the column. 

 Rows 

o Click and drag on the numbers of the rows (left edge) to highlight the desired rows. 

o Move the cursor to a line between the row numbers at the left (two-headed arrow). 

o Click and drag to adjust the height of the row. 

 When the mouse button is released, the selected group adjusts to the same width/height. 

Document Properties 

 Document Properties contain hidden information in the spreadsheet such as the name of the author, the 

title, and keywords. 

 Properties may be edited to remove information. 

 Click on the Microsoft Office Button. 

 Place the cursor over Prepare and then click on Properties. 

 Click in the box of the information to be altered and make the 

desired changes. 

 To close the Document Properties window, click on the X at 

the top on the far right. 

Hiding and Unhiding Rows, Columns, or Sheets 

Row(s) 

 To hide a row, click in a cell of the row to be hidden. 

o On the Ribbon, click on the Home tab. 

o In the Cells group, click on the Format button and choose Hide & Unhide  Hide Rows. 

o OR right click on the row indicator and choose Hide. 

 Note - Click and drag to select several cells in a column to select several rows to be hidden. 

 To unhide a row, click and drag to highlight cells above and below the hidden row(s). 

o On the Ribbon, click on the Home tab. 

o In the Cells group, click on the Format button and choose Hide & Unhide  Unhide Rows. 
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Column(s) 

 To hide a column, click in a cell of the column to be hidden. 

o On the Ribbon, click on the Home tab. 

o In the Cells group, click on the Format button and choose Hide & Unhide  Hide Columns. 

o OR right click on the column indicator and choose Hide. 

 Note - Click and drag to select several cells in a row to select several column(s) to be hidden. 

 To unhide a column, click and drag to highlight cells above and below the hidden column(s). 

o On the Ribbon, click on the Home tab. 

o In the Cells group, click on the Format button and choose Hide & Unhide  Unhide Columns. 

Unhiding the Row 1 or Column A 

 Click on the cell above the row 1 indicator. (See illustration.) 

 This will select the entire worksheet. 

 On the Ribbon, click on the Home tab. 

 In the Cells group, click on the Format button and choose Hide & Unhide  

Unhide Rows (Columns). 

Sheet(s) 

 To hide a sheet, click on the tab of the sheet to be hidden. 

o On the Ribbon, click on the Home tab. 

o In the Cells group, click on the Format button and choose Hide & 

Unhide  Hide Sheets. 

o OR right click on the sheet tab and choose Hide. 

 To unhide a sheet,  

o On the Ribbon, click on the Home tab. 

o In the Cells group, click on the Format button and choose Hide & Unhide  Unhide Sheets. 

o Select the sheet to unhide. 

o Click on OK. 

Special Pasting 

 Several special pasting features are available by clicking on the Paste down arrow . 

 Copy the cells that have the information, formatting, or other information desired. 

 Click in the cell where the information or formatting is to be pasted. 

 Click on the Paste down arrow and choose  

o Paste – Performs a regular paste. 

o Formulas – Pastes just the formulas. 

o Paste_Values – Pastes the numbers shown in the cells without the formulas which created them. 

o No Borders – Performs a regular paste without any borders. 

o Transpose – Pastes rows as columns and columns as rows. 

o Paste_Link – Performs what appears to be a regular paste but links the cells so that changes made 

in the original cell(s) are communicated to the pasted cells. 

o Paste Special… - Allows various options for pasting through choices in a window. 

o Paste as Hyperlink – Creates a hyperlink to the source information in the spreadsheet. 

o As Picture – Provides the option of copying a portion of the spreadsheet as a picture rather than 

text and numbers and then pasting it as a picture. 
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Using Paste Special 

 Copy the cell(s) that have the information, formatting, or other information desired. 

 The highlighted cells now have a “marching ant border.” As long as the “ants are marching,” 

those cells can be pasted with paste or paste special. 

 Click in the cell where the information or formatting is to be pasted. 

 On the Ribbon, click on the Home tab. 

 In the Clipboard group, click on the Paste down arrow and choose 

the type of paste desired.

 In the Operation section, choose the operation to be performed with 

the numbers from the copied section.  

o Choose None if no operation is desired. 

 Transpose causes a row to be pasted as a column or a column to be 

pasted as a row. 

 Click on the Paste Link button to create a dynamic link between the 

copied cells and the destination cells.  

 Click on OK. 

Using Paste > As Picture 

 Highlight the cell(s) to be made into a picture. 

 On the Ribbon, click on the Home tab. 

 In the Clipboard group, click on the Paste down arrow and choose As Picture  

Copy as Picture…. 

 In the Copy Picture window, make the desired choices and then click on OK. 

 Click where the picture is to be pasted. 

 On the Ribbon, click on the Home tab. 

 In the Clipboard group, click on the Paste down arrow and  choose As Picture  

Paste as Picture… or Paste. 

Format Painter 

 Click in the cell with the desired formatting. 

 On the Ribbon, click on the Home tab. 

 In the Clipboard group, click on the Format Painter button. 

 Click and drag over the cells to be formatted. 

Formatting Several Selections 

 Click in the cell with the desired formatting. 

 On the Ribbon, click on the Home tab. 

 In the Clipboard group, double click on the Format Painter button. 

 Click and drag over the cells to be formatted. 

 Click on the Format Painter button to turn the tool off. 
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Formatting as a Table 

 Sections of a worksheet can be formatted as a table. 

 Select the section of the spreadsheet to be formatted. 

 On the Ribbon, click on the Home tab. 

 In the Styles group, click on the Format as Table button and 

choose a style. 

 Click and drag in the spreadsheet to select the area to be formatted as a table. 

 Click on OK. 

 Filters are turned on automatically. 

 To turn off the filter,  

o On the Ribbon, click on the Home tab. 

o In the Editing group, click on the Sort and Filter button and choose Filter. 

Naming the Table 

 A table can be named for easy access. 

 On the Ribbon, click on the Design tab of the Table Tools. 

 In the Properties group, click in the Table Name box and enter a name. 

 The name of the table can only contain letters and numbers and cannot contain spaces. 

 Press the Enter key. 

Navigating to the Table 

 Click in the Name Box on the left end of the Input Line. 

 Enter the name of the table and then press the Enter key. 

Table Styles 

 Click in the table. 

 On the Ribbon, click on the Design tab of the Table Tools. 

 In the Table Styles group, place the cursor over a style to see the results. 

 Click on the Up button, the Down button, or the More button to see additional choices. 

 Click on the desired style. 

Table Style Options 

 Click in the table. 

 On the Ribbon, click on the Design tab of the Table Tools. 

 In the Table Style Options group, click to add or remove options. 

Converting the Table to a Normal Range 

 Click in the table. 

 On the Ribbon, click on the Design tab of the Table Tools.  

 In the Tools group, click on the Convert to Range button. 

 In the window, click on Yes. 
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Dynamic Links 

 A dynamic link causes the information in the original cell to be displayed in the second cell. 

 Click in the cell where the information should be seen. 

 Type an equal sign (=). 

 Move to the location of the original information and click in that cell. 

 Press the Enter key. 

Pasting a Link 

 Click in the cell with the information. 

 On the Ribbon, click on the Home tab. 

 In the Clipboard group, click on the Copy button. 

 Move to the location where the information should be seen. 

 In the Clipboard group, click on the Paste down arrow and choose Paste Link. 

Formulas 

Entering Formulas  

 Click in the desired cell.    

 On the Ribbon, click on the Formulas tab. 

 In the Function Library group, click on the down arrow to the right of the Auto Sum button. 

 Choose the appropriate function. 

 Note – The marching ants indicate the cells included in the formula. 

 Press the Enter key. 

Writing a Formula  

 Click in the cell where the formula should go. 

 Type an equals sign (=). 

 Select cells to be included by clicking and dragging. 

 Enter the proper operations  

 Press the Enter key. 

Order of Operations 

 To be sure to get the desired results, use the proper order of operations. 

 A mnemonic to remember the order is: Please Excuse My Dear Aunt Sally. 

1. Please (Parenthesis) - Things contained in parenthesis. 

2. Excuse (Exponents) - Exponential calculations. 

3. My (Multiplication) Dear (Division) - Multiplication or division. (A combination of these reads 

from left to right.) 

4. Aunt (Addition) Sally (Subtraction) - Addition or subtraction. (A combination of these reads from 

left to right.) 

Entering More Complex Formulas 

 Click in the cell where the function is to be placed. 

 On the Ribbon, click on the Formulas tab. 

 In the Function Library group, click on the Insert Function button. 

 Find the desired function in the list of the Insert Function window. 

 Click on OK. 

 Choose or enter the necessary information for the function. 

 OR click on the Insert function button on the Input Line. 
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Finding a Formula  

 Click in the cell where the formula should go. 

 On the Ribbon, click on the Formulas tab. 

 In the Function Library group, click on the Insert Function button. 

 In the Search for a function box, enter a description of what the 

function should do. 

 Click on the Go button. 

 Some choices appear in the Select a function box.  

 Click on one of the functions to see a description in the space below 

the box. 

 Click on the desired function in the Select a function box. 

 Click on OK. 

IF Formula 

 Click in the cell the formula is to be in. 

 On the Ribbon, click on the Formulas tab. 

 In the Function Library group, click on the Insert Function button. 

o OR click on the Insert function button on the Input Line. 

 Click on IF in the Select a function box. 

 When IF is not in the Select a function box: 

o In the Search for a function box, enter if. 

o Click on the Go button. 

o Click on IF in the Select a function box. 

 Click on OK. 

 Logical Test 
o The logical test checks the condition to 

determine if it is true or false.  

o If the cell is empty or contains a 0, it is 

marked false. If the cell contains a number 

other than 0, it is marked true. 

o To choose a particular cell, click on the red 

dot at the end of the box, click on the 

desired cell, and then press the Enter key. 

 Value if true 
o The content of the cell appears when the 

logical test is true. 

o Text must be enclosed in double quotes. For example, “Number is too large”. 

o To have no text appear, type in double quotes. For example, “”. 

o To have the contents of another cell appear, click on the red dot at the end of the box, click on the 

desired cell, and then press the Enter key. 

 Value if false 
o The content of the cell appears when the logical test is false. 

o Text must be enclosed in double quotes. For example, “Number is too small”. 

o To have no text appear, type in double quotes. For example, “”. 

o To have the contents of another cell appear, click on the red dot at the end of the box, click on the 

desired cell, and then press the Enter key. 

 Click on OK.  
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Protecting Cells/Worksheets 

What is happening? 

 Cells are protected by default. 

 The protection does not take effect until the sheet is protected. 

 Unlock the cells where the information will be able to be changed. 

 Then protect the sheet. 

Unlocking Cells 

 Highlight the cells to be unprotected. 

 On the Ribbon, click on the Home tab. 

 In the Cells group, click on the Format button and choose Lock Cells. 

 The Lock Cells button is highlighted if the cells are locked. 

Protecting the Sheet 

 On the Ribbon, click on the Home tab. 

 In the Cells group, click on the Format button and choose Protect Sheet…. 

 Enter a password if desired. (The password is needed to unprotect the sheet.) 

 Select the desired options. 

o Click to remove the check mark in front of Select locked cells. 

o Leave the check mark in front of Select unlocked cells. 

o Only unlocked cells will be able to be 

selected. 

 Click on OK. 

 Enter the password again. 

 Click on OK.  

Unprotecting the Sheet 

 On the Ribbon, click on the Home tab. 

 In the Cells group, click on the Format button and choose Unprotect Sheet…. 

 Enter the password. 

 Click on OK. 

Protecting the Workbook 

 On the Ribbon, click on the Review tab. 

 In the Changes group, click on the Protect Workbook button and choose Protect 

Structure and Windows. 

 Enter a password. (The password is needed to unprotect the workbook.) 

 Select Structure to protect the structure of the workbook such as adding, deleting, 

or unhiding worksheets. 

 Select Windows to protect the windows of the workbook from being resized. 

 Click on OK. 

 Enter the password again. 

 Click on OK.  

 Note – To restrict access to the workbook the 

Information Rights Management client must be 

installed. 
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Unprotecting the Workbook 

 On the Ribbon, click on the Review tab. 

 In the Changes group, click on the Protect Workbook button and choose 

Protect Structure and Windows to remove the check mark. 

 In the Unprotect Workbook window, enter the 

password. 

 Click on OK.  

Fills 

 Using the Fill Handle is an effective way to copy or fill information into cells. 

 Click in the cell with the information. 

 Move the cursor to the bottom right corner of the cell. The cursor changes to a thin plus sign. 

 Right click and drag over the cells where the information is to be filled in. 

 Choose the desired option: 

o Copy Cells fills the cells with an exact copy of the information in the first cell. 

o Fill Series fills the cells with a regular series of numbers, days of the week, etc. 

o Fill Formatting Only fills the cells with the format of the first cell but not the information. 

o Fill Weekdays fills the cells with the days of the week, excluding Saturday and Sunday. 

 Linear Trend and Growth Trend take the number in the first cell and fill the cells with a number 

progression. 

Custom Fills 

 Click on the Microsoft Office Button and then click on the 

Excel Options button at the bottom of the window. 

 In the pane on the left, click on Popular. 

 Under the Top options for working with Excel, click on the 

Edit Custom Lists button. 

 Type the list into the List entries box. 

 Note - Each item should be on its own line. 

 Click on the Add button and then click OK. 

Custom Fill from a List 

 Click on the Microsoft Office Button and then click on the Excel Options button at the bottom of the 

window. 

 In the pane on the left, click on Popular. 

 Under the Top options for working with Excel, click on the Edit Custom Lists button. 

 Click on the button with the red dot next to the Import button. 

 Click and drag to highlight the desired list. 

 Click on the Import button and then click OK. 

Deleting a Custom List 

 Click on the Microsoft Office Button and then click on the Excel Options button at the bottom of the 

window. 

 In the pane on the left, click on Popular. 

 Under the Top options for working with Excel, click on the Edit Custom Lists button. 

 In the Custom Lists box, click on the list to be deleted. 

 Click on the Delete button. 

 Click on OK. 
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Conditional Formatting 

 The cell format can be made to change based on the contents of the cells. 

 Click in the cell to be formatted. 

 On the Ribbon, click on the Home tab. 

 In the Styles group, click on the Conditional Formatting button and choose the desired rule or 

formatting. 

o Highlight Cell Rules – Choices include Greater Than…, Less Than…, Between…, Equal 

To…, Text that Contains…, A Date Occurring…, Duplicate Values. 

o Top/Bottom Rules – Choices include Top 10 Items…, Top 10%..., Bottom 10 Items…, Bottom 

10%..., Above Average…, Below Average…. 

o Data Bars – Choose color bars to be displayed in the cell. 

o Color Scales – Choose color scales to be displayed in the cell. 

o Icon Sets – Choose the icon sets to be displayed in the cell. 

 Enter the desired information in the window. 

 Click on OK. 

Clearing Conditional Formatting 

 Click in the cells with the conditional formatting. 

 On the Ribbon, click on the Home tab. 

 In the Styles group, click on the Conditional Formatting button and choose the Clear Rules  Clear 

Rules from Selected Cells. 

Sorting/Filtering by Color 

 Lists can be sorted or filtered by color. 

 To turn on filtering, on the Ribbon, click on the Home tab. 

 In the Editing group, click on the Sort & Filter button and choose 

the Filter. 

 To sort by color, click on the Filter button at the top of the column 

to be filtered, click on Sort by Color  and choose the desired color or no fill. 

 To filter by color, click on the Filter button at the top of the column to be filtered, click on Filter by Color 

 and choose the desired color or no fill. 

Managing Rules 

 Click in the cell with the conditional formatting. 

 On the Ribbon, click on the Home tab. 

 In the Styles group, click on the Conditional 

Formatting button and choose the Manage 

Rules…. 

 To edit a rule, click on the desired rule and make 

the desired changes. 

 To change the order of the rules,  click on the rule 

to be changed and then click on the Move Up 

button or the Move Down button as desired. 

 To delete a rule, click on the rule and then click on the Delete Rule button. 

 To add a new rule, click on the New Rule button.  Make the desired choices in the New Formatting Rule 

window and then click on OK. 

 Click on OK. 
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Data Bars 

 Data Bars provide an instant bar graph in a cell with a number. The bars are 

automatically scaled to match the range of the cells highlighted. 

 Highlight the cells to be formatted. 

 On the Ribbon, click on the Home tab. 

 In the Styles group, click on the Conditional Formatting button, move the 

cursor over Data Bars, and then select the desired color. 

 Resize the column to display the data bars at the desired width. 

Turning Off Data Bars 

 Highlight the cells with data bars. 

 On the Ribbon, click on the Home tab. 

 In the Styles group, click on the Conditional Formatting button, move the cursor over Clear Rules, then 

select Clear Rules from Selected Cells. 

Color Scales 

 Color Scales provide a color bar to indicate whether the number in the cell 

is at the top, in the middle, or at the bottom of the range. 

 Highlight the cells to be formatted. 

 On the Ribbon, click on the Home tab. 

 In the Styles group, click on the Conditional Formatting button, move 

the cursor over Color Scales, and then select the desired color scale. 

Turning Off Color Scales 

 Highlight the cells with color scales. 

 On the Ribbon, click on the Home tab. 

 In the Styles group, click on the Conditional Formatting button, move the cursor over Clear Rules, then 

select Clear Rules from Selected Cells. 

Icon Sets 

 Icon Sets provide icons to indicate where the number in the cell is in 

the range. 

 Highlight the cells to be formatted. 

 On the Ribbon, click on the Home tab. 

 In the Styles group, click on the Conditional Formatting button, 

move the cursor over Icon Sets, and then select the desired icon set. 

Turning Off Icon Sets 

 Highlight the cells with color scales. 

 On the Ribbon, click on the Home tab. 

 In the Styles group, click on the Conditional Formatting button, 

move the cursor over Clear Rules, then select Clear Rules from Selected Cells. 

Documentation 

 Documentation can provide important instructions for: 

1. Other persons who will use the spreadsheet. 

2. The creator of the spreadsheet.  We all forget with the passage of time. 

 Comments are a great way to provide documentation. 
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Comments 

 A comment is like a sticky note. 

 They usually do not print and remain hidden until the cursor is placed over the cell with the comment. 

 Cells with comments have a red triangle in the top right corner. 

Inserting Comments 

 Click in the cell where the comment is to be placed. 

 On the Ribbon, click on the Review tab. 

 In the Comments group, click on the New Comment button. 

 Enter the comment. The name of the author can be erased. 

 Click away from the comment box when finished. 

Seeing Comments 

 Place the mouse over a cell with a comment and the comment box appears. 

Editing Comments 

 Click in the cell with the comment. 

 On the Ribbon, click on the Review tab. 

 In the Comments group, click on the Edit Comment button. 

 Edit the comment as needed. 

 Click away from the comment box when finished. 

Resizing the Comment Box 

 Click in the cell with the comment. 

 On the Ribbon, click on the Review tab. 

 In the Comments group, click on the Edit Comment button. 

 Place the cursor over one of the handles (white boxes on the edge). (The cursor is a two-headed arrow.) 

 Click and drag to the appropriate size. 

Moving the Comment Box 

 Click in the cell with the comment. 

 On the Ribbon, click on the Review tab. 

 In the Comments group, click on the Edit Comment button. 

 Place the cursor over the edge of the comment box. (The cursor is a four-headed 

arrow.) 

 Click and drag the comment box to the desired location. 

Removing a Comment Box 

 Click in the cell with the comment. 

 On the Ribbon, click on the Review tab. 

 In the Comments group, click on the Delete button. 
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Printing Comments on the Worksheet 

 On the Ribbon, click on the Review tab. 

 In the Comments group, click on the Show All Comments button. 

 Note - This makes the comments visible on the page. 

 On the Ribbon, click on the Page Layout tab. 

 In the Page Setup group, click on the Dialog Launcher 

button. 

 Click on the Sheet tab. 

 In the Print section, click on the down arrow after 

Comments. 

 Choose As displayed on sheet. 

 Click on OK and then print the worksheet. 

Printing Comments at the End of the Worksheet 

 On the Ribbon, click on the Review tab. 

 In the Comments group, click on the Show All 

Comments button. 

 Note - This makes the comments visible on the page. 

 On the Ribbon, click on the Page Layout tab. 

 In the Page Setup group, click on the Dialog Launcher button. 

 Click on the Sheet tab. 

 In the Print section, click on the down arrow after Comments. 

 Choose At end of sheet. 

 Click on OK and then print the worksheet. 

Shapes 

Inserting Shapes 

 Shapes provide decorative elements and places for comments. 

 They can also provide a graphic model to clarify information on the 

spreadsheet. 

 On the Ribbon, click on the Insert tab. 

 In the Illustrations group, click on the Shapes button and choose the 

desired shape. 

o Recently Used Shapes 

o Lines  

o Rectangles 

o Basic Shapes 

o Block Arrows 

o Equation Shapes 

o Flowchart 

o Stars and Banners 

o Callouts 

 In the document, click and drag to create the shape in the desired 

location. 

 Make adjustments to the shape as desired. 

 Note – If the object has yellow diamonds, these are used to change 

the proportions of the object. 
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Adding Text to an Object 

 Right click on the object and select Edit Text. 

 Enter the desired text. 

 Use the Mini toolbar to change the font, font size, font color, etc. 

 Click away from the object. 

Moving an Object 

 Click on the object and move the cursor to the edge. 

 Click and drag the object to the desired location. 

Resizing an Shape 

 Click on the shape. 

 Move the cursor over one of the handles. (The open circles at the corners and the middle of each edge.) 

 The cursor will change to a two-headed arrow. 

 Click and drag to the desired size.  

 Note – If the object has yellow diamonds, these are used to change the proportions of the object. 

Connecting the Tail of the Callout 

 Click on the callout. 

 Notice the yellow diamond at the end of the tail of the callout. 

 Click and drag it to the desired location. 

Deleting an Object 

 Click on the object. 

 Press the Delete key on the keyboard. 

Showing/Hiding Shapes, Charts, and Comments 

 Shapes and charts can be hidden of displayed with the click of the mouse. 

 On the Ribbon, click on the Page Layout tab. 

 In the Arrange group, click on the Selection Pane button. 

 In the Selection Pane on the right, each of the shapes, charts, and comments 

on the worksheet are listed with the picture of an eye to the right. 

 To hide the shape or chart, click on the eye icon. 

 To show a hidden shape or chart, click on the box where the eye icon was. 

Data Validation 

 Data validation is the process of setting limits that are checked when data is entered. 

 Data validation helps ensure the accuracy and usefulness of the data. 

 Data can be validated against a list or specific numbers. 

 The data can be evaluated as being a whole number, a decimal, a list, a date, a time, a text length, or 

custom. 

 The conditions to choose from include between, not between, equal to, not equal to, greater than, less than, 

greater than or equal to, and less than or equal to. 

 For example, choosing from a list is faster and more accurate than typing in the information. 

Creating the List 

 In a separate area of the worksheet, create the list. 

 The list should run down a column. 
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Setting up the Cell 

 Click in the cell where the list is to be used. 

 On the Ribbon, click on the Data tab. 

 In the Data Tools group, click on the Data 

Validation button. 

 Click on the Settings tab. 

 Click on the Allow box down arrow and choose List. 

 Click on the button at the end of the Source box. 

 Highlight the cells with the desired list. 

 Press the Enter key. 

 Click on OK. 

 If subsequent cells need the same data validation, use the fill feature. 

Using the List 

 Click in the cell where the list is to be used. 

 Click on the down arrow and choose the desired item from the list. 

Editing the List 

 Make corrections to the list (original list) as needed. 

 To add a new item to the list: 

o Right click in a cell in the middle of the list and choose Insert. 

o Choose Shift cells down and then click OK. 

o Enter the information in the cell. 

 To delete an item from the list: 

o Right click in the cell to be deleted and choose Delete. 

o Choose Shift cells up and then click OK. 

Clearing the Data Validation 

 Click in the cell(s) where the list is used. 

 On the Ribbon, click on the Page Layout tab. 

 In the Data Tools group, click on the Data Validation button. 

 Click on the Settings tab. 

 To clear the data validation from all cells with the same setting, click at the bottom of the window to Apply 

these changes to all other cells with the same settings. 

 Click on the Clear All button. 

 Click on OK. 

Getting Data 

 Data can be obtained from a variety of sources. 

 Data in a table in a Word document can be pasted directly into Excel. 

 Data which is not organized as a table can be organized into columns if the information on each line is 

consistently organized and separated by a comma, a tab, or some other marker. Files with commas 

separating the data are csv files. 

  



Page 18 

Educational Technology Center 

Davis School District, Farmington, Utah  84025 Revised 2/19/2009 

Text to Columns 

 From a source such as http://earthquake.usgs.gov/eqcenter/catalogs/ , copy the CSV file information and 

paste it into an Excel spreadsheet. 

 On the Ribbon, click on the Data tab. 

 In the Data Tools group, click on the Text to Columns 

button. 

 Click to choose Delimited as the type of data. 

 Click on Next. 

 In the Delimiters section, choose the delimiter such as Comma. 

 The Data preview box shows the data in columns. 

 Click on the Finish button. 

Charts 

Using Charts 

 Charts can be an effective visual presentation showing a comparison of items, changes over time, parts of a 

whole, trends, and correlations. 

o Comparisons, Changes over Time, and Trends – Use a column chart, a bar chart, a line chart, a cone 

chart, a pyramid chart, area chart, or surface chart. 

o Parts of a Whole - Use a pie chart, a doughnut chart, a stacked column chart, or a stacked bar chart. 

o Correlations – Use an X Y (Scatter) chart or a Bubble chart. 

o Note – A radar chart shows data from a central point in a circle. 

Resizing a Chart 

 Click on the chart. 

 Place the cursor over an edge of the chart. The cursor changes to a two-headed arrow. 

 Click and drag the chart to the desired size. 

 Note – To maintain the same proportions, hold down the Shift key and use the corner to resize the chart. 

Chart Tools 

 Chart Tools are shown in three tabs when a chart is selected. 

 Design tab – Contains the Type, Data, Chart Layouts, Chart Styles, and Location groups. 

 Layout tab – Contains the Current Selection, Insert, Labels, Axes, Background, Analysis, and 

Properties groups. 

 Format tab – Contains the Current Selection, Shape Styles, WordArt Styles, Arrange, and Size groups. 

Changing the Chart Type 

 Click on the chart to select it. 

 On the Ribbon, click on the Design 

tab of Chart Tools. 

 In the Type group, click on the 

Change Chart Type button.  

 Click on the desired chart type in the list on the 

right. 

 Choose the desired chart subtype. 

 Click on OK. 

  

http://earthquake.usgs.gov/eqcenter/catalogs/
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Switching Rows and Columns 

 Switching rows and columns changes the way the data is represented on the chart. 

 Click on the chart to select it. 

 On the Ribbon, click on the Design tab of Chart Tools. 

 In the Data group, click on the Switch Column/Row button.  

Choosing the Chart Layout  

 Click on the chart to select it.  

 On the Ribbon, click on the Design tab of Chart Tools. 

 In the Chart Layouts group, click on the More button at the bottom right 

corner of the Chart Layouts.  

 Click on the desired layout. 

Choosing the Chart Style  

 Click on the chart to select it.  

 On the Ribbon, click on the Design tab of Chart Tools. 

 In the Chart Styles group, click on the More button at the bottom 

right corner of the Chart Styles.  

 Click on the desired style. 

Selecting Data for the Chart 

 Click on the chart to select it.  

 On the Ribbon, click on the Design tab of Chart Tools.  

 In the Data group, click on the Select Data button. 

 To change the range of cells used in the chart: 

o Click on the button with the red dot at the 

end of the Chart data range box. 

o Click and drag to select the desired data. 

o Click on the button with the red dot OR press the 

Enter key. 

 To move the Select Data Source window, click on the title 

bar and drag it to the desired location. 

 To switch the data in the rows with the columns, click on 

the Switch Row/Column button.  

 To add more cells used in the chart: 

o Click on the Add button. 

o Click on the button with the red dot at the end of the Series name 

box. 

o Click and drag to select the name (label) for the new data. 

o Click on the button with the red dot OR press the Enter key. 

o Click on the button with the red dot at the end of the Series values 

box. 

o Click and drag to select the values (data) for the new part. 

o Click on the button with the red dot OR press the Enter key. 

o Click on OK. 

 To remove a range of cells used in the chart: 

o In the Legend Entries box, click on the item to be removed. 

o Click on the Remove button. 

 Click on OK. 
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Changing the Chart Location  

 The chart can be a picture floating on top of the 

worksheet, or a separate worksheet. 

 Click on the chart to select it.  

 On the Ribbon, click on the Design tab of Chart 

Tools. 

 In the Location group, click on the Move Chart button.  

 Click on the desired location. 

 Click on OK. 

Customizing the Chart 

 Click on the part of the chart to work with. 

 On the Ribbon, click on the Layout tab of Chart Tools. 

 In the Current Selection group, click on the down arrow of the 

Chart Elements button and choose the 

desired element of the chart 

 OR click on the element of the chart to be customized.  

 In the Current Selection group, click on the 

Format Selection button.  

 To move the window, click on the title bar and drag to the desired 

location. 

 In the left pane, click on the attribute of the element to be changed. 

 In the right pane, make the desired changes to the element. 

 Click on the Close button. 

Reseting the Chart 

 Click on the part of the chart to work with. 

 On the Ribbon, click on the Layout tab of Chart Tools. 

 In the Current Selection group, click on the down arrow of the Chart Elements 

button and choose the desired element of the chart 

 OR click on the element of the chart to be customized.  

 In the Current Selection group, click on the Reset to Match Style button.  

Chart Labels 

 Click on the chart to work with. 

 On the Ribbon, click on the Layout tab of Chart Tools. 

 The Labels group contains buttons for working with Chart Title, 

Axis Titles, Legend, Data Labels, and Data Table. 

 In the Labels group, click on the appropriate button and choose the 

desired option. 

 Choosing More … Options… allows for the item to be customized. 

Chart Axes 

 The horizontal and vertical axes can be easily formatted. 

 Click on the chart to work with. 

 On the Ribbon, click on the Layout tab of Chart Tools.  

 The Labels group contains buttons for working with Axes and Gridlines. 

 In the Axes group, click on the appropriate button and choose the desired option. 

 Choosing More … Options… allows for the item to be customized. 
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Plot Area 

 The chart can be given a background color, gradient, or picture. 

 Note – The background should be simple so as to not make the chart hard to read. 

 Click on the chart to work with. 

 On the Ribbon, click on the Layout tab of Chart Tools. 

 In the Background group, click on the Plot Area button and choose the desired option. 

 Choosing More Plot Area Options… allows for the title to be customized. 

Formatting the Chart 

 Click on the chart to work with. 

 Click on the element of the chart to be formatted. 

 On the Ribbon, click on the Format tab of Chart Tools. 

 To format a shape: 

o In the Shape Styles group, click on the More 

button at the bottom right corner of the Shape 

Styles window. 

o Click on the desired style. 

o Note – Live Preview in Office 2007 displays the shape with the style the mouse is hovering over. 

o To change the fill of the shape, in the Shape Styles group, click on the Shape Fill button and 

choose the desired fill. 

o To change the outline of the shape, in the Shape Styles group, click on the Shape Outline button 

and choose the desired outline. 

o To change the effect of the shape, in the Shape Styles group, click on the Shape Effects button 

and choose the desired effect. 

 To format text: 

o In the WordArt Styles group, click on the More button at 

the bottom right corner of the WordArt Styles window. 

o Click on the desired style. 

o Note – Live Preview in Office 2007 displays the text with 

the style the mouse is hovering over. 

o To change the fill of the shape, in the WordArt Styles group, click on the Text Fill button and 

choose the desired fill. 

o To change the outline of the shape, in the WordArt Styles group, click on the Text Outline 

button and choose the desired outline. 

o To change the effect of the shape, in the WordArt Styles group, click on the Text Effects button 

and choose the desired effect. 

Pasting a Chart into Word or PowerPoint 

 A chart that is created in Excel can be copied and pasted into Word or PowerPoint. 

 Click on the chart to select it. 

 On the Ribbon, click on the Home tab. 

 In the Clipboard group, click on the Copy button. 

 Open the Word or PowerPoint document the chart is to be pasted into. 

 On the Ribbon, click on the Home tab. 

 In the Clipboard group, click on the Paste button. 

 The chart is dynamically linked to that changes made in the spreadsheet are immediately communicated to 

the chart in Word or PowerPoint. 
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Custom Views 

Creating a Custom View 

 On the Ribbon, click on the View tab. 

 In the Workbook Views group, click on the Custom Views button. 

 Click on the Add… button.  

 Enter a name for the view. 

 To include printer settings, leave the checkmark in front of Print 

settings. 

 To include hidden rows, columns and filter settings, leave the 

checkmark in front of Hidden rows, columns and filter settings. 

 Click on OK. 

Seeing a Custom View 

 On the Ribbon, click on the View tab. 

 In the Workbook Views group, click on the Custom Views button. 

 Click on the desired view. 

 Click on the Show button. 

Deleting a Custom View 

 On the Ribbon, click on the Page Layout tab. 

 In the Workbook Views group, click on the Custom Views button. 

 Click on the desired view. 

 Click on the Delete button. 

 Click on the Yes button to delete the selected view. 

 Click on the Close button. 

Page Layout View 

 Page Layout view shows how the pages will be printed without going into Print Preview. 

 On the Ribbon, click on the View tab. 

 In the Workbook View group, click on the Page Layout button. 

Returning to Normal 

 Click and drag to select the area to be printed. 

 On the Ribbon, click on the View tab. 

 In the Workbook View group, click on the Normal button. 

Page Break Preview 

 Page Break Preview shows how the pages will be printed without going into Print Preview. 

 On the Ribbon, click on the View tab. 

 In the Workbook View group, click on the Page Layout button. 

 Click on OK on the window indicating the page breaks can be adjusted by 

clicking and dragging.  

 Blue dotted lines indicate page breaks. 

 To adjust a page break, place the cursor over the blue line indicating the 

page break and crag it to the desired location. (The blue line becomes 

solid blue.) 
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Inserting a Page Break 

 Click in the cell that is to be the first cell on the new page. 

 On the Ribbon, click on the Page Layout tab. 

 In the Page Setup group, click on the Break button and choose Insert Page Break. 

Removing a Page Break 

 Click in the cell just after or just below the page break. 

 On the Ribbon, click on the Page Layout tab. 

 In the Page Setup group, click on the Break button and choose Remove Page Break. 

Resetting All Page Breaks 

 Resetting all page breaks removes adjustments to the page breaks. 

 On the Ribbon, click on the Page Layout tab. 

 In the Page Setup group, click on the Break button and choose Reset All Page Break. 

Print Area 

 Setting the print area tells the computer to print just the selected part of the spreadsheet. 

Setting the Print Area 

 Click and drag to select the area to be printed. 

 On the Ribbon, click on the Page Layout tab. 

 In the Page Setup group, click on the Print Area button and choose Set Print Area. 

Clearing the Print Area 

 Click in the spreadsheet. 

 On the Ribbon, click on the Page Layout tab. 

 In the Page Setup group, click on the Print Area button and choose Clear Print Area. 

Printing Multiple Worksheets 

 Click on the tab of the first worksheet to be included. 

 Hold down the Control key and click on each additional worksheet that is to be printed. 

 Click on the Microsoft Office Button and choose Print  Print Preview. 

 Check the pages to be sure they will print as desired. 

 Click on the Print button. 

 To release the grouping of the sheets, click on a sheet tab not in the group. 
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Multiple Page Printouts 

Titles Repeated on Every Page 

 Close Print Preview. 

 On the Ribbon, click on the Page Layout tab. 

 In the Page Setup group, click on the Print Titles button. 

 Click on the Sheet tab. 

 Click on the red arrow at the right of Rows to repeat at top. 

 Click in the row with the headers you want repeated. 

 Press the Enter key. 

 Click on the red arrow at the end of the Columns to repeat at left. 

 Click in the column with the headers you want repeated. 

 Press the Enter key. 

 Click on OK. 

Saving as PDF 

 To save or export a file to PDF, you must first install the Save as PDF add-in from the Microsoft Office 

website. 

o Go to http://www.microsoft.com  

o Type PDF in the search box located in the upper right corner. 

o Click on the result that says: Download details: 2007 Microsoft Office Add-in:… 

o Click on the Continue button next to “Validation required.” 

o After your computer has been validated, click on the Download button. 

o Click on Run. 

o Click on Run. 

o Check the box to Accept the Microsoft Software License Terms. 

o Click on Continue. 

o Click on OK. 

 Once the PDF add-in has been installed to the computer, open the 

document that needs to be converted to PDF. 

 Click on the Microsoft Office Button, place the cursor over Save 

As…, and click on PDF. 

 Navigate to the location where the PDF document will be saved. 

  (Optional) Type in a file name.  

 Click on the Options button. 

 Make choices in the Options window to determine what part of the 

spreadsheet will be included in the pdf. 

 Click on OK. 

 Click on Save. 

 

http://www.microsoft.com/

